Intermittent issues accessing Fusebill Services
Incident Report for Stax Bill
Resolved
This incident has been resolved.
Posted Oct 14, 2021 - 08:45 EDT
Investigating
Fusebill has been notified that our service providers are currently experiencing an issue which is impacting access to Fusebill services
Posted Oct 14, 2021 - 07:45 EDT
This incident affected: API, Admin Interface, Hosted Checkout Pages, Transparent Redirect, and Self Service Portal.