Intermittent issues accessing Fusebill Admin
Incident Report for Fusebill
Resolved
This incident has been resolved.
Posted Oct 13, 2021 - 13:42 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 13, 2021 - 12:54 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 13, 2021 - 08:04 EDT
Investigating
We are currently investigating this issue.
Posted Oct 13, 2021 - 07:30 EDT
This incident affected: Admin Interface.